ارتباطات و فناوري اطلاعاتامور زیربنایی

آسیب‌پذیری بحرانی در محصولات جنکینز

جنکینز یک ابزار متن‌باز است که برای توسعه، استقرار و اتوماسیون پروژه‌ها مورد استفاده قرار می‌گیرد اما محصولاتش دچار یک ‫آسیب‌پذیری بحرانی شدند که می‌تواند منجر به تخریب حافظه و همچنین افشای اطلاعات محرمانه شود.

به گزارش آرمان اقتصادی، جنکینز (Jenkins) یک ابزار متن‌باز است که برای توسعه، استقرار و اتوماسیون پروژه‌ها مورد استفاده قرار می‌گیرد. طبق اطلاعات مرکز ماهر (مدیریت امداد و هماهنگی رخدادهای رایانه‌ای) شرکت Jenkins در خصوص یک ‫آسیب‌پذیری بحرانی در «وب‌سرور Jetty» که می‌تواند منجر به تخریب حافظه و همچنین افشای اطلاعات محرمانه شود، هشدار داد. این آسیب‌پذیری بحرانی با شدت ۹.۴ شناخته می‌شود و بر نرم‌افزار Eclipse Jetty ثر می‌گذارد.

جنکینز از طریق یک رابط خط فرمان به نام Winstone از سرور Jetty استفاده می‌کند و هنگام استفاده از هر یک از نصب‌کننده‌ها یا بسته‌ها اجرا می‌شود. این آسیب‌پذیری ممکن است به یک مهاجم بدون نیاز به احراز هویت امکان دسترسی به سرآیندهای مربوط به پاسخ HTTP که ممکن است حاوی اطلاعات حساسی باشند، فراهم ‌کند.

پایگاه خبری آرمان اقتصادی 61720664 آسیب‌پذیری بحرانی در محصولات جنکینز

تخریب حافظه یا memory corruption این امکان را برای کلاینت فراهم می‌کند که بین نشست‌ها حرکت کند و از این طریق به حساب‌های کاربری دیگر دسترسی داشته باشد، زیرا کوکی‌های احراز هویت از پاسخ یک کاربر به یک کاربر دیگر ارسال شده است و کاربر A می‌تواند در جلسه کاربر B پرش کند.

این آسیب‌پذیری که در ماه گذشته در Jetty 9.4.30.v20200611 منتشر شده بود، وصله شد. جنکینز این نقص را در برنامه‌های خود در Jenkins 2.243 و Jenkins LTS 2.235.5 وصله کرده است. به کاربران Jenkins توصیه می‌شود به منظور کاهش نقض تخریب (corruption) در بافر، هر چه سریع‌تر نرم‌افزار خود را به آخرین نسخه به‌روزرسانی کنند.

انتهای پیام

منبع

ایسنا

  کد خبر
532462
کلیدواژه‌ها

اخبار مرتبط

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

بستن